Trouble getting KT controller/LCD3 working with Voilmart motor

General Discussion about electric bicycles.
Post Reply
cgokey   1 W

1 W
Posts: 51
Joined: Jun 09 2016 2:43pm

Trouble getting KT controller/LCD3 working with Voilmart motor

Post by cgokey » May 23 2021 3:32pm

So I have an existing voilamart motor 1000W motor and bought that KT controller 48v controller with a KT LCD3. The throttle is working but not much else. Has anyone done this and able to configure the controller to work with this motor? No luck with PAS and not registering any speed. It does register watts used when I use the throttle though.

Any help getting this working would be appreciated!
Chris

cgokey   1 W

1 W
Posts: 51
Joined: Jun 09 2016 2:43pm

Re: Trouble getting KT controller/LCD3 working with Voilmart motor

Post by cgokey » May 23 2021 4:45pm

So according to this thread, the PAS sensor was the result of changing the wires, i.e,
https://www.pedelecs.co.uk/forum/thread ... kit.40299/
"On the PAS there are red, white and black and from the controller, yellow, black and brown. They are connected as follows;
black to yellow
white to black
red to brown"

"That's why it doesn't work. it should be black to black, red to brown and yellow to white.
The white wire is for a speed sensor integrated into the motor. if you don't have the speed sensor in your motor, you need to connect an external one if you want to see your speed on the LCD and ypur system not to go to sleep every 5 minutes or whatever it's set to."
So I connected black to black, red to brown, white to yellow. PAS now works! Although still not seeing speed...
Any idea what might be up with why I'm not seeing speed?

Chris

qwerkus   10 kW

10 kW
Posts: 709
Joined: Jul 22 2017 4:00am

Re: Trouble getting KT controller/LCD3 working with Voilmart motor

Post by qwerkus » May 23 2021 4:50pm

cgokey wrote:
May 23 2021 4:45pm
So according to this thread, the PAS sensor was the result of changing the wires, i.e,
https://www.pedelecs.co.uk/forum/thread ... kit.40299/
"On the PAS there are red, white and black and from the controller, yellow, black and brown. They are connected as follows;
black to yellow
white to black
red to brown"

"That's why it doesn't work. it should be black to black, red to brown and yellow to white.
The white wire is for a speed sensor integrated into the motor. if you don't have the speed sensor in your motor, you need to connect an external one if you want to see your speed on the LCD and ypur system not to go to sleep every 5 minutes or whatever it's set to."
So I connected black to black, red to brown, white to yellow. PAS now works! Although still not seeing speed...
Any idea what might be up with why I'm not seeing speed?

Chris
White line. Sometimes its marked "cs" on the board

cgokey   1 W

1 W
Posts: 51
Joined: Jun 09 2016 2:43pm

Re: Trouble getting KT controller/LCD3 working with Voilmart motor

Post by cgokey » May 23 2021 5:08pm

There is a six pin connector that go from the motor to the controller but # of wires and colors all match up:
Red->red
Blue->Blue
Black-Black
Green->Green
Yellow->Yellow

Which wire controls speed or could this just be a setting in the KT controller I have to change?

Here are my current settings:
P1 - 46
P2 - 1
P3 - 1
P4 - 0
P5 - 15

C1 - 0
C2 - 0
C3 - 8
C4 - 0
C5 - 10
C6 - 3
C7 - 0
C8 - 0
C9 - 0
C10 - N
C11 - 0
C12 -4
C13 - 0
C14 - 2

Chris

cgokey   1 W

1 W
Posts: 51
Joined: Jun 09 2016 2:43pm

Re: Trouble getting KT controller/LCD3 working with Voilmart motor

Post by cgokey » May 23 2021 8:53pm

So it appears P2 needs to be set to 0 not 1.
https://www.pedelecs.co.uk/forum/thread ... cd3.34132/

It is registering speed now! Tomorrow is take it out for as spin, see if any other adjustments are needed.

cgokey   1 W

1 W
Posts: 51
Joined: Jun 09 2016 2:43pm

Re: Trouble getting KT controller/LCD3 working with Voilmart motor

Post by cgokey » May 26 2021 8:54pm

Just a follow up with this. I really like the KT controller + lcd over the one that came with the voilamart motor (sw900). The pedal assist is way more responsive, and the various pedal assist levels actually work, Level one maxes out around 150 Watts, configurable to be less.

Post Reply