Optimistic Kelly

Electric Motors and Controllers
User avatar
zener   1 kW

1 kW
Posts: 353
Joined: Jan 16 2014 5:48pm

Re: Optimistic Kelly

Post by zener » Apr 02 2014 4:49pm

Its a joke.
They have no lag but you can set one in the settings...

User avatar
gwhy!   1 MW

1 MW
Posts: 1651
Joined: Jun 08 2011 3:47pm
Location: Bristol, Uk

Re: Optimistic Kelly

Post by gwhy! » Apr 02 2014 4:52pm

zener wrote:Its a joke.
They have no lag but you can set one in the settings...
with the ramp set to 0 it still has lag or it just maybe because due to the lack of phase current either way it make it very slugish off the line.

User avatar
zener   1 kW

1 kW
Posts: 353
Joined: Jan 16 2014 5:48pm

Re: Optimistic Kelly

Post by zener » Apr 02 2014 5:02pm

gwhy! wrote:
zener wrote:Its a joke.
They have no lag but you can set one in the settings...
with the ramp set to 0 it still has lag or it just maybe because due to the lack of phase current either way it make it very slugish off the line.
Was this with a CA in the line?

User avatar
gwhy!   1 MW

1 MW
Posts: 1651
Joined: Jun 08 2011 3:47pm
Location: Bristol, Uk

Re: Optimistic Kelly

Post by gwhy! » Apr 02 2014 5:20pm

zener wrote:
gwhy! wrote:
zener wrote:Its a joke.
They have no lag but you can set one in the settings...
with the ramp set to 0 it still has lag or it just maybe because due to the lack of phase current either way it make it very slugish off the line.
Was this with a CA in the line?
no CA just a very simple setup, looking for max punch off the line with everthing maxed out.

User avatar
zener   1 kW

1 kW
Posts: 353
Joined: Jan 16 2014 5:48pm

Re: Optimistic Kelly

Post by zener » Apr 02 2014 5:29pm

gwhy! wrote:
zener wrote:
gwhy! wrote:
with the ramp set to 0 it still has lag or it just maybe because due to the lack of phase current either way it make it very slugish off the line.
Was this with a CA in the line?
no CA just a very simple setup, looking for max punch off the line with everthing maxed out.
Than its maybe not enough battery voltage and/or too high KV motor? Or you have bought a number too low KW Kelly.


User avatar
zener   1 kW

1 kW
Posts: 353
Joined: Jan 16 2014 5:48pm

Re: Optimistic Kelly

Post by zener » Apr 02 2014 6:49pm

crossbreak wrote:hey zener, which kelly do you use and what max bat amps do you see? thx!
Its the KEB72451X 6KW on bat is no problem.

User avatar
gwhy!   1 MW

1 MW
Posts: 1651
Joined: Jun 08 2011 3:47pm
Location: Bristol, Uk

Re: Optimistic Kelly

Post by gwhy! » Apr 02 2014 6:52pm

It was a side by side comparison against a 12fet controller so same battery not totally sure what kelly it was but it would have been bought on the assumption that it was at least 100 battery amps the motor just a small gng type so motor speed would not have been a issue. It would not touch the 12fet off the line. I will find out what modle number the kelly was next time I talk to my colleague.

Bluefang   10 kW

10 kW
Posts: 589
Joined: Aug 27 2010 9:34am
Location: Australia, Goldcoast

Re: Optimistic Kelly

Post by Bluefang » Apr 02 2014 9:27pm

Have you changed the throttle settings in the Kelly? Balanced seems to give a improvement in power over speed and torque
Building high powered electric vehicles.
http://www.facebook.com/ausemoto
Goldenmotor dealer in Queensland, Australia.

User avatar
crossbreak   100 MW

100 MW
Posts: 2879
Joined: Aug 02 2011 11:20am
Location: Germany
Contact:

Re: Optimistic Kelly

Post by crossbreak » Apr 03 2014 12:53am

zener wrote:
crossbreak wrote:hey zener, which kelly do you use and what max bat amps do you see? thx!
Its the KEB72451X 6KW on bat is no problem.
So max bat´current is about the same as max cont. motor current in Kelly specs? Thanks. That seems to be fine to me

User avatar
zener   1 kW

1 kW
Posts: 353
Joined: Jan 16 2014 5:48pm

Re: Optimistic Kelly

Post by zener » Apr 03 2014 4:30am

crossbreak wrote:
zener wrote:
crossbreak wrote:hey zener, which kelly do you use and what max bat amps do you see? thx!
Its the KEB72451X 6KW on bat is no problem.
So max bat´current is about the same as max cont. motor current in Kelly specs? Thanks. That seems to be fine to me
They are actually a little underrated.
You can calculate the max. bat power by take 80% from the max const.- and peak phase.
But its always better to invest $50 more in a bigger controller than u actually need than running it always in max.

User avatar
dan974   1 kW

1 kW
Posts: 414
Joined: Jun 12 2012 1:36am
Location: Reunion Island

Re: Optimistic Kelly

Post by dan974 » Apr 03 2014 5:34am

crossbreak wrote:maybe it is just their price police. Anyway.. can anyone with experience answer the above questions please?? Thanks!!
your stuff is wrong...

I git the KEB726000 and I got +8KW battery peaks...easly...their 6Kw rating is for 72V 110A nominal motor current...so ~ x0.7 @ battery current...so I had 190A peak battery current with it your peak battery current is false...it's 0.7 x motor current peak so : 240A x0.7= 168 battery peak current I fact I mesure +15% with my shunt and the CA...

User avatar
dan974   1 kW

1 kW
Posts: 414
Joined: Jun 12 2012 1:36am
Location: Reunion Island

Re: Optimistic Kelly

Post by dan974 » Apr 03 2014 5:39am

gwhy! wrote:
zener wrote:Its a joke.
They have no lag but you can set one in the settings...
with the ramp set to 0 it still has lag or it just maybe because due to the lack of phase current either way it make it very slugish off the line.
here you can adapt the "lag" of the throttle(T up/down rate)
Image
and here you can see the 0.7=70%
Image

maybe 100% on the KBS model
Image
and the start/end Throttle voltage signal to setup the dead zone and the Full throttle not to have to break your arm from dead to FT..(T effective starting/ending)
Image
Last edited by dan974 on Apr 03 2014 5:48am, edited 1 time in total.

User avatar
dan974   1 kW

1 kW
Posts: 414
Joined: Jun 12 2012 1:36am
Location: Reunion Island

Re: Optimistic Kelly

Post by dan974 » Apr 03 2014 5:42am

crossbreak wrote:gwhy: Throttle LAG!?!? In a $$$ controller!?! Is this a joke as well? I must test this!

From: http://endless-sphere.com/forums/viewto ... 09#p874679
dan974 wrote:
crossbreak wrote:about our Kelly: It seems that it does only around 3/5 as battery current of the rated 55A "motor current". That would be 33A battery current for our chosen one. For 20s Li-ion we should see 2442W peak. Not 4kW :oops: this motor will be bored a bit: http://endless-sphere.com/forums/viewto ... 77#p858870
130 peak should give you 0.7 x130 =90a peak, and able to give 40A continuous.... My 240 rated peak key gave me 189A ( battery) in thé sand, and easy 110 A boost on flat the question is : are you able to handle a 72V 90a peak ? Don't forget the kelly is a square/truesin mix,... I think the guy you mention was never able to setup it....but I do not know kbs only key ones....
http://kellycontroller.com/faqs.php
http://kellycontroller.com/KBShelp.php

Set motor at 100% if you don t care heating it
And battery % according to the peak value and the I precomize 60% OF YOUR battery C discharge not to destroy it...for exemple a 8ah 30c = 240 A take 144A as max discharge not to damage...so set at 100% battery (or maybe 70% is max like on keb model) If you got a 20c 8ah, 160 À discharge, take 96A AS REAL, THEN downgrade the battery current to 70 % to protect from too much discharge, or if your sag is too much
Take nite that the software can give you full motor current at low speed because of current multiplication....so it could be your battery pack discharge rate that limit, if you haveore Amp, you reduce the sag and so you get a higher Discharge C
Kelly recommend to get 2 to 3 time the power motor rated.....72V*55A =4kW rated should be ok for a 1500/2000w rated motor....
Correct me if I m wrong...ask gindc why is truesin is more powerfull and faster with less amp

User avatar
dan974   1 kW

1 kW
Posts: 414
Joined: Jun 12 2012 1:36am
Location: Reunion Island

Re: Optimistic Kelly

Post by dan974 » Apr 03 2014 5:44am

They are actually a little underrated.
:D :D :D

User avatar
dan974   1 kW

1 kW
Posts: 414
Joined: Jun 12 2012 1:36am
Location: Reunion Island

Re: Optimistic Kelly

Post by dan974 » Apr 03 2014 5:56am

space4dreamz wrote:
Doctorbass wrote:
The LVC i'm reffering to is the one that your controller is set to... ex: LVC is 36V for 12s lipo...

Doc

OK, got you now. But like I wrote - The battery is "hot of the charger" and its way far from the controller LVC limit, it's around 47.5V (under load).
I dont think it's a case of cut off at all cause I'm not feeling any "cut" on the throttle.
It's probably just a case of marketing high numbers as opposed to real life numbers (phase current opposed to line current).

Thanks again Doc.
I think Doc was refering to the undervoltage software setup......
Image

User avatar
dan974   1 kW

1 kW
Posts: 414
Joined: Jun 12 2012 1:36am
Location: Reunion Island

Re: Optimistic Kelly

Post by dan974 » Apr 03 2014 6:05am

Bluefang wrote:Have you changed the throttle settings in the Kelly? Balanced seems to give a improvement in power over speed and torque
torque : throttle = I(amp command) so FT give you fastest acceleration, but you loose to speed @ end
speed : give a voltage command, so try to reach the speed you ask @ throttle give you max speed (slow ramp)
balanced : a mix of the two : try to reach the speed you ask @ Throttle with and theTorque the same : FT give you max torque to reach max speed; 50% throttle will give you half the max torque to reach the speed ask

User avatar
crossbreak   100 MW

100 MW
Posts: 2879
Joined: Aug 02 2011 11:20am
Location: Germany
Contact:

Re: Optimistic Kelly

Post by crossbreak » Apr 03 2014 7:28am

but you loose to speed @ end
Dont get it. Can you explain please?

I calced the spreadsheet with factor 0.7 instead of 3/5. more realistic now?
Attachments
kelly_price_policy.png
kelly_price_policy.png (23.34 KiB) Viewed 2940 times

User avatar
dan974   1 kW

1 kW
Posts: 414
Joined: Jun 12 2012 1:36am
Location: Reunion Island

Re: Optimistic Kelly

Post by dan974 » Apr 03 2014 7:37am

crossbreak wrote:
but you loose to speed @ end
Dont get it. Can you explain please? I d'ont know I think as @ the nominal speed the current decrease, and so as you're alreay @ full throttle amp signal it doesn't alow you to give him more amp to reach top end speed further than the nominal speed of the motor were I beguin to decrease, it was strang and it is how I justify, but this should be tested again, maybe I had a limitation...
I still playing which settings and we aren't talking about regen which can stop you pretty fast @100% pushing you on the bar, so you can block rear wheel with a little press on the lever or get it with the front brake give you a kind of ABS system ...

I calced the spreadsheet with factor 0.7 instead of 3/5. more realistic now?
yep mayeb you can add +15% as they're underrated :wink:

User avatar
crossbreak   100 MW

100 MW
Posts: 2879
Joined: Aug 02 2011 11:20am
Location: Germany
Contact:

Re: Optimistic Kelly

Post by crossbreak » Apr 03 2014 7:44am

ok thanks. If they are as good as claimed i'll buy another one in the near future so i can do a side by side FT comparison. FT should make no difference with both controllers configured for the max power. The we can verify

User avatar
riba2233   1 MW

1 MW
Posts: 1847
Joined: Jun 30 2013 10:23am
Location: Croatia

Re: Optimistic Kelly

Post by riba2233 » Apr 04 2014 9:02am

I have kelly keb 48201x, which is rated 2kw, and i'm seeing 90 battery amps on CA max.
My electric moped: http://www.evalbum.com/4966

My electric car: http://www.evalbum.com/5364

Bluefang   10 kW

10 kW
Posts: 589
Joined: Aug 27 2010 9:34am
Location: Australia, Goldcoast

Re: Optimistic Kelly

Post by Bluefang » Apr 05 2014 5:11am

I have a pair of Kelly KEB72801 controllers. They power a hub monster at 32kw peak. They are only rated for 8kw and up to 72V but i am using them at 20S so 84V and each one is drawing 16kw. Both controllers run thru a calibrated shunt with a CA V3 giving readings. It does not matter what amps you see on the CA etc, all you should look at is the KW and compare that to the controllers rating.

The balanced setting, dont really care what the explanation of the settings is, its faster accellerating then both speed and torque in a few quick tests i did after someone mentioned it was better to me, Fany said torque would be fastest, I tried Balanced and it was faster. Speed has a AWESOME hit of power after 20% of speed :). Also Boost function should be disabled unless you actually have a button to activate and want to restrict your bike. It does not give any extra power it just limits you normal power.

The off the line power of a Kelly controller does not even compete with a Lyen or greentime controller. I would guess this is because they are controlled better and are always power limited. Where ebike controllers usually have block time where the controller can ofter put out 3-5 times its normal power, this comes at the cost of reliability.
Building high powered electric vehicles.
http://www.facebook.com/ausemoto
Goldenmotor dealer in Queensland, Australia.

User avatar
dan974   1 kW

1 kW
Posts: 414
Joined: Jun 12 2012 1:36am
Location: Reunion Island

Re: Optimistic Kelly

Post by dan974 » Apr 05 2014 5:31am

NEVER USE boost on the keb, it give you 100% power and desactivate throttle.... It kicked my ass on the ground... I misszd read the manual, it 100 % not 0~100% imax..
I forgot that Fany told me it is for elevator application.... Variable approach with throttle then full power....
After having my keb running at 20s I now make it run at 21s max limit for the 90v given by it

drew12345   10 kW

10 kW
Posts: 899
Joined: Oct 16 2013 8:34pm
Location: MD, USA

Re: Optimistic Kelly

Post by drew12345 » Apr 06 2014 7:03am

Just saw this thread. I have kelly kbs4810 with AFT Mid Drive and 48v 12s of lipo. I hit 60 amps the other day. I think these controllers are awesome. I haven't changed any settings other than throttle response. Amazing for their small size. It came with my aft/cyclone motor.

Edit: Sorry, meant 60amp with my AFT mid drive. You can see in video below.

User avatar
crossbreak   100 MW

100 MW
Posts: 2879
Joined: Aug 02 2011 11:20am
Location: Germany
Contact:

Re: Optimistic Kelly

Post by crossbreak » Apr 11 2014 7:53am

I could test the Kelly now. Does not work as expected. The most reason i bought it was that it has "Torque Mode Throttle" available in Setup. But that is no real Torque mode Throttle. It's a Speed throttle. It's not as twitchy as the Infineons and X8m06c Speed throttles, but still no torque throttle :roll: An Infineon with a good throttle mapper/tamer isn't worse than this.

BUT what concerns me most: If i let go the throttle (zero throttle) after Full Throttle , it does NOT REDUCE TORQUE INSTANTLY!!! WTF???!?!? Even the cheapest controllers response faster on Zero Throttle :evil:

I programmed it to FASTEST Throttle Response. What a waste of time :roll:

EDIT: I failed, just had to deactivate "smooth setting" in setup.. it's awesomely fast throttle response now

Last edited by crossbreak on Apr 11 2014 10:01am, edited 2 times in total.

Post Reply