Tongsheng TSDZ2 OSF connection issues


1 µW
May 6, 2023
I have recently purchased a Tongsheng TSDZ2 48v 750w kit from PSWpower to replace my previous TSDZ2 36v 250w motor (also purchased from PSWpower). I have a VLCD5 and wanted to use the open source firmware on the unit (the embrusa firmware for the VLCD5 screen).

I bought an ST link adaptor from Amazon and wired it up as the instructions on the wiki to a speed sensor extension cable (see image). Connecting it to the speed sensor cable running to the motor. I’ve tried the ST link software and the Java tool and I’m unable to get a connection on Windows 10 (with drivers installed) or Linux. It just refuses to connect. Any ideas why this will not work? I purchased another ST link USB dongle from another amazon seller and that won’t connect either.

The cable does not work with my old 36v motor or the new 48v motor.

I have significantly shortened the cable.
I have tried with windows 10 and 11 installed on a fairly modern laptop and a separate desktop PC. Also tried Linux and no joy with any of them.

I tested the voltage on the pin shown above for the 48v motor and it reads 5v so I assume it's version 1 of the controller.

I did try 3.3v instead of 5v and no difference.

tried with a much shortened cable (see attached pics) at 3.3 and 5v. No change. Any other suggestions before I give up? I've tried 2 STlink clones from different vendors and no joy.

IMG_5765.jpegIMG_5766.jpegScreenshot 2023-05-06 111143.png
Issue resolved. The STlink dongle needed a firmware update. Once updated it now connects ok and I've flashed the motor.