Tsdz2 not working please help!


1 µW
Jun 4, 2023

I bought a tsdz2 36v last summer and flashed it with the open source firmware. It's worked really well for me and now has 500 miles.
Over the winter it had to live outside (covered) but when I got it out again recently the pedals would not turn. After applying some oil i got them working again and the motor seemed ok (although making a slightly 'gritty' sound)

However on my most recent ride the motor just suddenly stopped working entirely - no power at all, no intermittent power, just dead.
The display (XH-18) and battery continue to work fine, no error codes or anything unusual, battery is at 60-80% or so, but absolutely no response from the motor.
Walk assist does nothing. Speed sensor is working fine and registering speed as normal. I've tried unplugging and replugging the cables, but no joy.

I'm wondering if the controller might be dead? I'm not quite sure what to try next and was thinking of just ordering a new motor, but this seems a shame for only 500 miles of use.

Can anyone help me?

Thank you! Tim (Brighton)
Thanks raylo32 for your reply. There is no brake message and I don't have any brake sensors fitted...
How would I check the contacts?
You wouldn't. The switches are in the levers or the add-on sensors. I was just thinking that if you had those, they might be corroded from the bike being parked outside as much as yours was.

Thanks raylo32 for your reply. There is no brake message and I don't have any brake sensors fitted...
How would I check the contacts?
If the display is still working/semi-working, then the controller is at least semi-working. It sounds like you started with a mechanical issue, which can lead to electrical issues, and the seized bearings may indicate moisture ingress, even though you had the bike covered. If any other bearings/components were also affected, they could be creating enough drag/resistance leading to burning up the motor. You may want to do some quick testing to rule out a burned up motor, before ordering parts. If you remove the cover, it should be easy to access the 3 phase wires, unscrew them, and test for phase to phase shorts. If they are fine, you may need to disassemble a little more to test the halls, but at that point you'll also be able to test the controller for shorts as well.
I had issue with mine. Opened up motor. Needle ratchet gear had disintegrated. The part is inside the gear. The new B redesigned motor has a different part to replace it. I ended up buying the new motor.
Hmm yes thanks everyone. Think I will take the motor apart and have a look but doesn't sound very hopeful! Maybe I'll order a new motor and then if I successfully repair this one at least I'll have a spare...