• Howdy! we're looking for donations to finish custom knowledgebase software for this forum. Please see our Funding drive thread

Endless Sphere 2.0 Preview - please provide feedback!

Status
Not open for further replies.
AW, let's talk about your wishlist on another thread once the dust has settled.

Some things on your list are easy, others very hard. Right now i'm just trying to figure out if we got the permissions working :)
 
still testing, nothing to report about that yet

I still don't see anything for moderator tools anywhere.

but this is different from earlier today:

before, the Home link at the top didn't do anything but take me to the same place the forums did. Now it takes me to the old es image home page that says to click to enter the forums,
https://test.endless-sphere.com/
and doing that takes me to a test server version of ES1.x, not to ES2.0.
https://test.endless-sphere.com/forums/
 
That's due to me reverting the database, don't worry about that, we're just concerned with permissions.

If you scroll all the way to the top, you don't see the moderator bar?

2023-02-01 16_56_54-(4) Reported items _ XenForo.jpg
 
Nope. not in ancient firefox or latest chrome, with or without any extensions running


reminder to myself to add to wishlist
make default for everyone to "watch" anything they reply to or create a thread for (otherwise they have no idea anyone has replied to them unless they manually dig up the thread themselves or happen to run across it, since the defaults are not to watch or notify anyone of anything)
 
ugh, changed some other settings.. hit refresh and let's see if your view changes.
 
No I just get "Login As User", nothing else

wasn't sure what that meant so i tried my own name and got this
Oops! We ran into some problems.
You are already logged in. Please click here to return to the forum list.


if i use your name (esdev on there) then it works and logs me in as you and then i get these options

Approval queue Reports Moderator Admin Logout from: esdev




another set of reminders for myself:
stuff not being imported correctly from es 1.x profiles
ignored member list
friends list (called following in es2.0)



these things in the profile are unpopulated but seem to be from their names supposed to be imported from the old phpbb es1.x; if so that's not happening since i know i populated some of these fields

user_field_title.country
Required
user_field_desc.country

user_field_title.phpbb_interests
user_field_desc.phpbb_interests

user_field_title.phpbb_occupation
user_field_desc.phpbb_occupation

user_field_title.phpbb_icq
user_field_desc.phpbb_icq

user_field_title.phpbb_website
user_field_desc.phpbb_website

user_field_title.phpbb_yahoo
user_field_desc.phpbb_yahoo

user_field_title.phpbb_aol
user_field_desc.phpbb_aol

user_field_title.phpbb_location
user_field_desc.phpbb_location

user_field_title.phpbb_facebook
user_field_desc.phpbb_facebook

user_field_title.phpbb_googleplus
user_field_desc.phpbb_googleplus

user_field_title.phpbb_skype
user_field_desc.phpbb_skype

user_field_title.phpbb_twitter
user_field_desc.phpbb_twitter

user_field_title.phpbb_youtube
 
No I just get "Login As User", nothing else

wasn't sure what that meant so i tried my own name and got this
Oops! We ran into some problems.
You are already logged in. Please click here to return to the forum list.


if i use your name (esdev on there) then it works and logs me in as you and then i get these options

Approval queue Reports Moderator Admin Logout from: esdev

i expect i should not be able to log in as an admin if i'm only a moderator. ;)
 
Why you're getting 'login as user' and i am not is another level of mystery.
not good :O
Okay i've turned the test site off for the moment while i beat on it some more :p
 
Okay i think i have it licked.

In xenforo, putting someone in the moderator user group and then assigning all moderation privileges to that group doesn't make that person a moderator.
Setting them as a super moderator does.
Wouldn't have guessed that!

'login as user' should disappear from all moderator accounts and the home button should go back to test.endless-sphere.com/xenforo like before.

Let's give it one last try, i think i have it all correct.
 
BTW in this version a few things are missing:

signature fixes
sticky posts
the 'react' icons
and our custom emojis from ES.

All that stuff is collected into a nice bundle that will be on the final version, don't mind that.
There's also a few link color errors but those are pretty easy to fix after the fact ^_^

If the permissions are as expected we're good to go!
 
i see mod links at top now

Approval queue Reports Moderator

and they appear to work

but the actual tools / info is way harder to access than it should be, it's all in separate dropdowns, tabs, windows, etc, when it ought to all be in one page--not that it's much worse than in es1.x but i'd hoped that those writing xenforo had a clue about user friendliness, gui design, usefulness, saving time, etc. guess not, so that can all go in the feature request thread when it gets started. maybe if you make it usable then when it's done you can get something for your time when if you contribute it back to the xf project itself?

otherwise spam control is not going to be much fun on es2.0; maybe i'll be able to work out a routine for less time but on 1.x it usually takes just a few minutes total to check all the new members in a day for spammer potential. worry about that later.

so far thanks for all the work you've put in to make xf work for us; i wish they'd designed it better so you would have a lot less work to do
 
Yay! i'm glad the permissions work for moderators at least!

Reworking the way the moderator interface works within Xenforo would be a nightmare of a job because the code is super complex and over-engineered. We know this because we built a tool for recategorizing forum posts and it was a 3 month job, where at least 2 of those months were spent figuring out how to work with xenforo's internals.

My guess is that the spam prevention in Xenforo is better; if not, there's plugins we can try, and if that doesn't work, i will write a bespoke tool based on what would be an ideal workflow.

We should assess the situation once ES has about a week in it's new home.
 
Regular users - when you can get to it..

For one last time.. see if you can login and do the usual things..

...if that works then we're in the clear :)
 
neptronix said:
For one last time.. see if you can login and do the usual things..

and make sure to try to do things you should not be able to do.... ;)
 
Testing ES 2.0 Preview, logged in as regular (non-moderater) user.

Cannot find any mod tools or other accessible tools that should be above my (regular user) pay grade, so that is a good sign.

Had difficulties logging in-- got a couple of 502 Bad Gateways before it finally logged me in correctly.

I can keep on looking for moderator tools that I shouldn't have access to-- that is what you are trying to fix ATM?

ADDED: Post reply works, with quoted text, preview, edit, and delete functions working mostly as they should. Except cascaded quotes do not appear, only the new text that was in the "quoted" post, not any previously quoted text that was in that post.
 
amberwolf said:
I don't see any way to tell which threads I've actually read vs unread, in this view (which is the main one I use). It may not be something you can fix, but thought you should know. I do not have any blocking of any kind setup on the test forum (I specifically disabled it all for that domain):
https://test.endless-sphere.com/xenforo/index.php?watched/threads
All icons, colors, etc appear identical even after I visit a thread via the date or time link on the far right and refresh this page. This means that if I am visiting the forum more than once a day (which is nearly every day) then to tell which ones I've already read to see if they had any new replies, I must re-open every thread for at least that day or that have "x minutes ago" on them, unless i keep track of how many minutes or hours ago it was I last visited each one, which is impractical at best.

ES 1.x uses both a large red page icon and a small red page icon at the left end of the post, which is itself a link to the last post (like the date or time is on the right end of 2.0), to indicate unread posts vs read ones which are a blue icon with a red star).
I think you may be describing the same issue as I did several weeks ago here:
https://www.endless-sphere.com/forums/viewtopic.php?f=13&t=118179&start=50#p1745331
 
Will get back to the other comments later on; putting the test server to sleep for a moment.
Thanks for helping me test!
 
This reminds me of a incident I had with a bank. Closed the account and walked home with all the cash. Few months later, got a letter about some fees. Fired up the internet and could see a few hundred dollars in the account. Called the bank to see whats up? Girl on the phone could not explain why I could see $$$?. She transferred me to the web expert. Think his name was Nep? He had no sense of humor. He said ARE YOU SURE YOU SEE THE MONEY? Yes I see it. He said try a different browser. Still see money. Try viewing on a phone. Yep still see a few hundred dollars.

Walked to the bank and withdrew all the money. Got cash :D Yes I robed the bank. My feeling on bank robbery. Stealing a few hundred dollars from a bank is like stealing a penny from the average person. Don't think they will miss it.
 
Did I just confess to a crime on the internet? Naa, Most likely I just made a math mistake when I closed the accounts. The money I thought I stole was really my money because I could see it.

Seriously - this was the first time I made a mistake. Once I thought I made a mistake but I was mistaken.
 
Good day sirs.
test.endless-sphere.com is back online and will be up for another 5 hours if you want to give it a look.

Apparently Xenforo doesn't have the capability to show read/unread after v1.5. There is a plugin that can restore this, and i've installed it on the test server.

We did more tests on the permissions and it looks like everything is finally 1:1.
I am very glad we did the last test because yesterday unearthed the same permissions issue we had on 1 of 2 development machines, where the backend will show that everything is 1:1 but have totally different effective permissions in reality.

Here's read/unread back in action:

read unread.jpg

Amberwolf, i also found where unanswered threads are:

unanswered threads.jpg

One outstanding thing is the multi quoted comment issue. This didn't seem to be a problem on the dev2 system. We have another mysterious discrepancy here but fixing the problem after the conversion should be easy. Changing the behavior of the editor works ( as amberwolf mentioned ) is difficult though.

For those who requested, i've found a way to make dark mode happen, so that will be added post-launch.

Are there any 'deal breakers' left in the system at this point? i'm thinking all the major bases are covered at this point.
 
I missed the 5-hour window but will watch for the next one as applicable.

Deducing from the read/unread graphic it looks like unread msgs are denoted by the dual red outlined thought bubbles? Thank You! for adding that. :thumb:
 
It's up if you want to give it any more testing.
 
Trying to figure out how the read/unread works. I see a thread with the read/unread icon, but clicking on it does nothing. What I expected is for the thread to open, to the beginning of the unread postings.
 

Attachments

  • tempsnip.png
    tempsnip.png
    23.9 KB · Views: 15
Status
Not open for further replies.
Back
Top